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T
he Photoshop CS6 workspace has had years to develop into a fine-tuned working environment, 
and with bigger monitors and faster processors, working in Photoshop has only become more 
fun. With all the space that larger display options give you, you can easily organize the panels, 

documents, and tools in the workspace to provide an efficient photo-editing environment.

With all its features, Photoshop can be a bit daunting at first. The purpose of this chapter is to 
familiarize you with the Photoshop workspace, how to navigate, find tools, customize settings, and 
set the environment so it works best for you.

Touring the Workspace
At first glance, the Photoshop workspace seems a little dreary, with a lot of gray, but that is mis-
leading. With beautiful photographs (or other colorful graphics) in the work area and fascinating 
tools at your fingertips, you’ll soon be addicted to the Photoshop playground. In fact, you may be 
glad that the background not only provides a good contrast to colorful files, but also is easy on 
the eyes.

06_9781118123881-ch02.indd   1506_9781118123881-ch02.indd   15 3/29/12   3:10 PM3/29/12   3:10 PM



16

Part I: Getting Started with Adobe Photoshop CS6

Therefore, without further ado, we give you the Photoshop workspace, as shown in Figure 2.1. 
There are four main components to the Photoshop workspace: the Photoshop menu bar, the 
document workspace, the Toolbox with option menus, and the panels. The following sections 
introduce you to each of these components, and later in this chapter, we’ll explore them in 
more detail.

FIGURE 2.1

The Photoshop workspace features four main components.

Toolbox

Photoshop menu bar

Tool Options bar

Panels

Document workspace

Cruising the Photoshop menu bar
The Photoshop menu bar, shown in Figure 2.2, houses sets of cascading menus that provide 
quick access to features, tools, and commands in Photoshop using only a few mouse clicks. 
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When you click a Photoshop menu bar item, a drop-down menu appears with several options. 
Each of these options performs different tasks such as opening dialog boxes to modify set-
tings, performing image adjustments, or even opening additional submenus. These menus are 
a critical part of the Photoshop workspace because they are the only way to access certain 
features in Photoshop.

FIGURE 2.2

Features of the Photoshop menu bar

Photoshop menu bar Submenu

Menu option set to active

Document doesn’t support menu item

Opens a dialog box

Opens a submenu

When navigating the menu bar in Photoshop, you need to understand the following basic 
points:

n If a menu item points to a submenu, there is an arrow to the right side, and if you 
hover over that item, the submenu pops up next to the open menu, as shown in 
Figure 2.2.

n If the menu item is only a setting, then a check mark appears when it is active, as 
shown in Figure 2.2. You can toggle the setting on and off by clicking the menu item.

n If the current document does not support the functionality of a menu item, then the 
menu item is grayed out, as shown in Figure 2.2. This means that the item is not 
active, and you cannot click it.

n If the menu item launches a dialog box, then an ellipsis (…) is displayed to the right, 
as shown in Figure 2.2.
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Looking at the document workspace
The document workspace houses the documents (image files) that you are currently editing. 
You will use the document workspace extensively as you view and edit documents in 
Photoshop.

The document workspace is also home to the panels and Toolbox discussed later in this chap-
ter. The workspace is large enough to give you the flexibility to expand your image to a larger 
size and keep your favorite panels open and docked as well.

NOTE

The screenshots in this book were taken at a screen resolution of 1024 x 768, which is a low resolution, especially if 

you have a larger screen. If your resolution is set higher, you have a larger work area than is shown here. If you set your 

resolution as high as 1920 x 1200 (which is what ours is usually set to), then you have enough space to expand your 

panels, tile your document windows, and generally make everything available to you at once. Of course, if your resolu-

tion is set lower than 1024 x 768, then your work area is smaller.

As you open image files, they appear in the center of the document workspace, and you have 
several options for viewing them. You can modify the view size and behavior, view specific 
information about a document, and arrange multiple documents in the view area.

Changing the view size of a document

Several ways exist to change the view size of a document in Photoshop to support the work-
flow that you are using. Changing the view size of a document is one of the most common 
tasks that you will perform in Photoshop, as you need to zoom in on an image to modify spe-
cific areas, enhance selections, and perform other tasks. You may also want to view the print 
size of an image, the actual screen size, or even fit the image to the screen so you can see all 
of it.

The View menu houses several different options to modify the view size of the document. 
When you click the View menu, as shown in Figure 2.3, you can choose the following options:

n Zoom In. Clicking this option, or press Ctrl+plus key/Ô+plus key, the image zooms 
up to the next zoom stop. The zoom stops are in various small increments such as 
.5%, .67%, 1%, 1.5% to large increments such as 100%, 200%, 300%, and so on.

n Zoom Out. Clicking this option, or press Ctrl+minus key/Ô+minus key, the image 
zooms out to the next zoom stop. The zoom stops are the same as for the Zoom In 
option.

n Fit on Screen. Clicking this option, you can see your entire image. This is your best 
option if you are working on your entire document (and not working with other 
files).

n Actual Pixels. Clicking this option, the pixels in the image match the pixels on the 
screen. Actual Pixels is the best option if you want to see the cleanest view of a spe-
cific area because no interpolation is necessary.
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n Print Size. Clicking this option, Photoshop shows you how the document will look 
when printed.

n Screen Mode. Clicking this option, you can choose from Standard Screen mode, Full 
Screen mode with menu bar, and Full Screen mode.

n Standard Screen Mode. This is the default mode, and it allows you to access 
other applications that are running.

n Full Screen Mode With Menu Bar. This mode looks similar to Standard Screen 
mode, but you can’t access other programs, for instance, through the Windows 
taskbar.

n Full Screen Mode. This mode hides everything but the selected document so you 
can work without distractions. The Photoshop tools are still available to you; just 
hover over the tool you want to use and it appears, or press the Tab key to view 
all of your tools. Press Esc to return to Standard Screen mode.

FIGURE 2.3

You can change the way your image fits into the document workspace by using the View menu.

TIP

Don’t use the zoom options in the View menu; you have several better options — the Zoom tool, the Magnify box, and 

the roller wheel on your mouse if you are using one — all of which are discussed later in this chapter. 

In addition to the standard zoom stops, you can easily zoom in and out on the image, 
depending on your editing needs. Notice that at the bottom-left corner of the document win-
dow in Figure 2.4, there is a percentage representing the zoom value and the document infor-
mation. You can change the size of your document by selecting the zoom value and typing a 
new percentage.
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Another way that you can change the magnification of an image is to select the Zoom tool in 
the Toolbox, and then click anywhere on the image and drag the mouse to the left or right. 
Dragging to the left decreases the size of the image, while dragging to the right increases it.

Viewing document information

Another useful feature in the document window is the information section at the bottom. By 
default, the document information displays the size of your file. Keep an eye on this as you 
begin to add multiple layers and effects to a document; you might be surprised by how these 
changes can increase the size of your document.

If you click the arrow next to the document information, a pop-up list opens, as shown in 
Figure 2.4 that gives you several options for the information display.

FIGURE 2.4

The information section of the document window can be very useful when you are editing 
images. The menu allows you to display several types of information.

Document tabs

Zoom amount Document info options

You can choose to display the following options at the bottom of the document workspace:

n Adobe Drive. This option shows the location of the Adobe drive used as a scratch 
disk.

n Document Sizes. This option shows the size data of the image in the format of “print 
size”/”actual size.” The print size represents the size of the image if it is in a flattened 
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state with no layers or additional channels. The actual size includes the additional 
space that the image takes to store the additional metadata such as channels and 
layers.

n Document Profile. This option displays the name of the color profile assigned to the 
document.

n Document Dimensions. This option displays the dimensions of the image in inches.

n Measurement Scale. This option shows the scale of the current zoom state of the 
document in pixels.

n Scratch Sizes. This option shows the scratch usage of the document in the format of 
“memory used for this document”/”total scratch memory available.”

TIP

The scratch usage can have a major impact on how Photoshop performs. You should monitor the scratch usage when 

making complex adjustments to very large images.

n Efficiency. This option displays the percentage of time that Photoshop uses to actu-
ally perform operations instead of reading or writing to the scratch disk. If this value 
is below 100 percent, then Photoshop is using the scratch disk and therefore opera-
tions are slower.

n Timing. This option displays the amount of time Photoshop used to complete the last 
operation.

n Current Tool. This option shows the name of the currently selected tool.

n 32-bit Exposure. This option provides a slider that allows you to easily adjust the 
preview image for viewing 32-bit HDR images on the monitor. The slider is only visi-
ble when you are working with a 32-bit document.

n Save Progress. This option opens a progress bar when you are saving an image. This 
is useful when you are saving large images in the background and you want to moni-
tor the progress of the save operation.

Arranging the view of multiple documents

When multiple documents are open in the document workspace, Photoshop provides tabs for 
each of them. These tabs display the document name, and you can access the document for 
editing by clicking its tab. Using the tabs is the most economical and organized way to have 
multiple files open, and you probably will prefer this option most of the time.

Other View options are also available when you have multiple documents open. To change 
how the document windows are organized, choose Window ➪ Arrange from the Photoshop 
menu bar and then choose one of the options shown in Figure 2.5.
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FIGURE 2.5

Using the Window ➪ Arrange menu, you can easily change the layout of multiple documents in 
the document workspace.

Preset documentation arrangements

Following is a description of the multiple document arrangement:

n Preset document arrangements. These options automatically distribute the docu-
ments in the document work area based on a predefined arrangement of view panes. 
These arrangements are shown next to the menu item. Each open document takes up 
one pane. If there are fewer documents than panes in the arrangement, the arrange-
ment option is inactive in the menu. If there are more documents than panes, then 
Photoshop places the extra documents as tabs in the top-left pane. Figure 2.6 shows 
the 3-up stacked arrangement. If the document is bigger than the pane, the scroll 
bars become active, allowing you to scroll around the image.

TIP

You can resize the view panes in a tiled or preset arrangement by dragging borders between the panes with the mouse. 

This allows you to customize your document workspace completely to support the files on which you are working. 

n Consolidate All to Tabs. This option docks all floating windows into the document 
workspace. This is great when you have so many windows open that navigating them 
is difficult. You can also consolidate windows to the document workspace or floating 
group by right-clicking the tab bar at the top and selecting Consolidate All to Here.
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n Cascade. This option cascades your documents by showing the document windows in 
a cascade fashion from the upper-left corner to the lower-right corner of your docu-
ment workspace. Figure 2.6 shows an example of a cascading document window.

n Tile. This option adjusts the size of all open document windows so you can view them 
together in the workspace. For example, if you are working with two or more docu-
ments at the same time, cloning areas of one into another, you probably want to tile 
your documents in the document workspace. Figure 2.6 shows an example of tiled 
documents that are in a floating state.

FIGURE 2.6

Examples of some of the multi-document layouts in Photoshop

Vertical pane border
3-up Stacked Horizontal pane border

Cascade Tile

Scroll bars
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n Float in Window. This option floats your documents, thereby releasing them from 
the document workspace or from a floating group to their own individual windows. 
When the document windows are floating, they are independent of the Photoshop 
interface, and you can use the standard operating system window controls on them. 
You can organize floating windows into groups by dragging one window on top of 
another window. When more than one document is in a floating group, their tabs are 
displayed at the top of the window. You can also float windows by grabbing the tab 
in the floating group or document workspace and dragging it out. You can add a 
floating document to a group or document workspace by dragging it into the tabs.

n Float All in Windows. This option causes all windows to float.

TIP

You can quickly cycle through open tabbed document windows by pressing the Ctrl+Tab/Ô+` hotkey sequence. 

n Match Zoom. This option sets the zoom percentage of all open document windows to 
match the value of the active document window. This is useful when you are working 
with multiple images that eventually will be consolidated into a single document.

n Match Location. This option sets the center panning position of all open document 
windows to match the center position of the active document window. This is useful 
if you are working with multiple versions of the same image or a sequence of images 
and you want to quickly move to the same location in all windows for comparison.

n Match Rotation. This option sets the rotation angle of the image in all document 
windows to match the rotation angle of the image in the active document window.

n Match All. This option sets the zoom, center panning position, and rotation of all 
document windows to match the values of the active document window.

Understanding the Toolbox and tool options bar
The Toolbox provides easy access to all of the tools in Photoshop that require mouse or stylus 
interaction with the document. The Toolbox includes selection tools, painting tools, erasing 
tools, and much more, as shown in Figure 2.7. We discuss each of the tools available in the 
Toolbox later in this chapter.

The tool options bar, usually referred to as the “options bar” or the “tool menu,” sits below 
the Photoshop menu bar. The options in the tool menu change, depending on the tool you 
have selected in the Toolbox. Figure 2.7 shows the different options for the Move, Brush, and 
Type tools.

It is always smart to keep an eye on what is going on in the options bar. When you select a 
tool, the options are set to default values that are commonly used, but not necessarily the 
values you would use in a particular situation. After you change the options for any given 
tool, those options stay changed, even after you use other tools. The options bar is useful and 
important and you’ll see you’ll see many examples throughout this book of different ways to 
set your options; and as you use Photoshop, you will soon become familiar with it.
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FIGURE 2.7

The Toolbox provides access to the mouse and stylus tools. Each time you select a new tool, 
the tool options bar changes to reflect settings for the new tool.

Understanding panels
The panels in Photoshop are similar to mini-applications with their own windows, controls, 
and menus. You will rely heavily on the Photoshop panels to do most of the editing. 
Photoshop has many panels, each of which provides its own set of functionality.

Panels tend to take up quite a bit of space in the work area, so Photoshop provides different 
display states for them. These states are expanded, collapsed into an icon, or hidden. To hide 
or unhide a panel, select the panel from the Window menu. Figure 2.8 shows a collapsed panel 
group as well as an expanded panel group. To collapse the panel group, click the Collapse but-
ton. To expand a panel in a collapsed group, click its icon.

NOTE

You will typically only have a small number of panels that pertain to your open workflow. This makes finding the panels 

you need much easier. 

A panel group is one or more panels that are connected to each other. To add a panel to a 
group, drag the panel or icon onto the group. To remove a panel from a group, drag the panel 
out of the group. Organizing panel groups is no different than organizing the items on your 
desktop. You can decide which panels go in which groups. The bottom line is, if you know 
where to find a panel, you can use it much faster.
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FIGURE 2.8

Panel groups can be collapsed to icons to reduce their footprint on the workspace.

Expand button Expand tabs

Collapse button

Panel menu

Panel buttonsPanel controls

The panel groups have the following basic components, as shown in Figure 2.8:

n Panel tabs. These tabs are used to select which panel is visible in the group and to 
drag panels out of the group.

n Collapse button. This button collapses the panel to an icon to reduce the footprint in 
the work area.

n Expand button. This button expands a collapsed panel from an icon to provide access 
to the panel settings.

n Panel controls. This area contains the controls used by the panel to perform various 
tasks. Each panel has different settings.

n Panel menu. This menu pops out of a panel when you click the menu button in the 
top-right corner. The panel menus usually contain additional features that are not 
included in the main settings area. If you can’t find something, it is probably in the 
panel.

n Panel buttons. These buttons are located at the bottom of a panel, and do things 
such as add or delete items or perform common tasks needed by the panel.

Another way to organize panel groups is to dock them either together or to the sides of the 
Photoshop workspace. You can dock panel groups by dragging the groups to the side or bot-
tom of another group. You can dock them to the side of the workspace by dragging them 
until the mouse is on the workspace edge.
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Using workspace presets
The workspace presets are quick ways to change the layout of the panels and tools in 
Photoshop, depending on the task you are performing. When you select a preset, the panel 
layouts are adjusted so you have easier access to the tools that are typically used for the 
selected task. You select a preset by choosing Window ➪ Workspace from the Photoshop menu 
bar and selecting one of the options from the drop-down menu:

n New in CS6. This preset displays the panel icons for panels with new features in CS6, 
such as the new 3D tools, paintbrush, paragraph and character presets, and Mini-
Bridge.

n Essentials. This preset gives you full access to the most commonly used panels in 
Photoshop, including the Navigation, Swatches, and Layers panels.

n Design. This preset displays the more common graphic design panels, such as the 
Swatches, Character, and Paragraph panels.

n Painting. This preset makes the paintbrush and brush presets readily available.

n Photography. This preset provides the Histogram and adjustment panels that make it 
easy to apply adjustments to photographs.

n 3D (Extended Only). This preset displays the 3D, Mask, and Layers panels that are 
often used when working with 3D objects.

n Motion (Extended Only). This preset displays the Timeline panel and Clone Source 
panel, which are frequently used in animation.

n Reset/New/Delete. These presets take advantage of the fact that Photoshop remem-
bers when you select a workspace preset and then adjust the panels, so you don’t 
have to readjust them each time you start the application. The Reset option restores 
the currently selected workspace to the original settings, so you can start over with a 
fresh set of panels. The New option allows you to save the current panel layout as 
your own custom workspace. The new workspace then shows up in the list. The Delete 
option deletes the currently selected workspace preset.

Exploring the Photoshop Menu Bar
Now that you are familiar with the Photoshop workspace, you are ready to explore the 
Photoshop menu bar. The menus along with their keyboard shortcuts will provide you access 
to the majority of the features in Photoshop. Throughout the book, we will discuss most of 
the options contained in the Photoshop menu bar in more detail. In this section, we show you 
the primary purpose of each menu and highlight some of the menu options that might not be 
covered in other areas of the book.
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Using the File menu
The File menu has many of the options that you would expect, and many of them are self-
explanatory. For the most part, all the options listed are different ways to open, save, or 
export your documents. The first task that you will be performing in Photoshop is opening or 
creating a document, so you will first need to become familiar with the File menu.

The options in the File menu, shown in Figure 2.9, are covered throughout the book: opening 
and saving files are covered in Chapter 3, exporting to the web and mobile devices are covered 
in Chapter 30, and batch operations on files are covered in Chapter 31.

FIGURE 2.9

The File menu in Photoshop provides several options to open, save, and export files.

Exploring the Edit menu
The Edit menu is a familiar menu found in most applications, with many recognizable options 
such as cut, copy, and paste as well as additional options that are specific to Photoshop. This 
menu is important for modifying the document and workspace settings.

Using the Edit menu, shown in Figure 2.10, you can step backward, undoing several of the 
most recent changes you made. Farther down the menu, you find the transformation edits, 
Content-Aware Scale and Puppet Warp among them; these are covered in Chapter 19. You 
learn about using color in Chapter 4 and color profiles in Chapter 29. Setting preferences and 
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using the menu and shortcut options to customize menu and shortcut behavior are covered 
later in this chapter.

NOTE

On Macs, the Preferences and Quit options are found under the Photoshop menu option on the left of the Photoshop 

menu bar. 

FIGURE 2.10

The Edit menu in Photoshop provides several options to modify document and workspace 
settings.

Using the Image menu
The Image menu is loaded with a lot of options for changing your image. Making changes to 
your image is different from making changes to your file, because these options actually 
affect the look of your image.
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Among other things, the options in your Image menu, shown in Figure 2.11, allow you to 
change the color mode, and resize, rotate, or duplicate your image. Neatly tucked into the 
Image Adjustments submenu, you find some of the most powerful tools for correcting the 
color and lighting of your image; these are covered in Chapter 13. The Apply Image and 
Calculations options blend the channels of your image and are covered in Chapter 11. Image 
variables and data sets allow you to create multiple images with similar components by defin-
ing and replacing layers. These options are covered in more detail in Chapter 10.

FIGURE 2.11

The Image menu in Photoshop provides several adjustment options to modify images.

The Image menu also provides an important submenu, shown in Figure 2.11, titled Analysis. 
The Analysis submenu is all about measuring and, of course, analyzing areas in your docu-
ment. You can customize the tools found here for your own use to measure, scale, and mark 
your images. You can choose from six menu options. We don’t list them in the order they 
appear in the Analysis submenu because they make more sense in the order listed here.

Ruler Tool

The Ruler tool is simply a tool that allows you to drag from one area in your image to another 
and measure it. The measurement information is displayed in the Info panel. By default, the 
measurement is displayed in pixels. The Ruler tool plays an important role in the other 
options found in the Analysis submenu.
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Count Tool

Selecting the Count tool and clicking your document leaves a number behind, in increments 
of one. This allows you to count and mark multiple items in your image. If you were trying to 
count a flock of birds, for instance, you would click each bird until they had all been marked. 
The last number placed would be the number of birds in the photo.

Record Measurements

Clicking Record Measurements opens the Measurement Log panel on the bottom of your docu-
ment window, as shown in Figure 2.12. As you create measurements, you click the Record 
Measurements button on the Measurement Log panel and the measurement details are 
recorded. Notice that the first measurement was taken by the Ruler tool, and the second mea-
surement was taken by the Count tool.

You can also use the Measurement Log to export these measurements. Simply click the Export 
icon to export the measurements as a text file to any specified location. You can also access 
the Measurement Log menu by clicking the menu icon.

FIGURE 2.12

The Measurement Log panel allows you to record and display measurements you have taken 
within your document.

Export

Set Measurement Scale

The measurement scale can be set to Default, which simply means that one pixel is equal to 
one pixel. If you choose the custom option, however, it allows you to translate a set number 
of pixels in your document to any other measurement you prefer.

For instance, in Figure 2.13, if you know the height of the bottom-right window pane is 20 
inches, you can choose Analysis ➪ Measurement Scale ➪ Custom to open the Measurement 
Scale dialog box. The Measurement Scale dialog box automatically activates the Ruler tool so 
you can measure from the bottom of the window pane to the top. In the photo, this measure-
ment is 225 pixels, shown as the pixel length in Figure 2.13. From here, you can enter any 
relative measurement that you choose — in this case, 20 inches. You could have just as easily 
entered 1 foot, 3 meters, or 7 girth units. You can save this measurement scale by clicking 
Save Preset and naming it.
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FIGURE 2.13

Placing a scale marker in your image allows you to clearly see the scale of the image.

After closing the Measurement Scale dialog box, you can activate the Ruler tool and measure 
other areas of the photo. These measurements are recorded in the Measurement Log panel. 
Notice that the third measurement in Figure 2.13 was taken after the Measurement Scale was 
set. The scale indicates that 225 pixels = 20 inches; the scale unit is inches and the length is 
20 (rounded up, of course).

Select Data Points

The Measurement Log shows data on each measurement you record. You can choose what data 
to keep and display by selecting specific data points. Choose Analysis ➪ Select Data 
Points ➪ Custom to display the Select Data Points dialog box. In this dialog box, you can dese-
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lect the types of information that you don’t want recorded. For instance, if you don’t require 
date and time information, you can deselect the box next to Date and Time. Every measure-
ment you take after this point no longer displays the date and time in the Measurement Log 
panel.

Place Scale Marker

You can place a scale marker in your image to denote scale. To place a scale marker, choose 
Place Scale Marker from the Analysis submenu to open the Measurement Scale dialog box, 
shown in Figure 2.13. You can choose the length of the scale by selecting more than one unit 
of measurement.

Refer to Figure 2.13, which shows a scale marker indicating that the unit of measurement rep-
resents the 20 inches that was set for the measurement scale. If you were to change the num-
ber from 1 to 2, your scale marker would appear twice as long and would be labeled 40 inches. 
You can also choose to display the text and what font and size that text will be. Finally, you 
have the choice to display the scale marker at the top or bottom of your document and in 
black or white.

Understanding the Layer menu
The Layer menu is built specifically for use with the Layers panel. Layers are an important 
part of working efficiently and non-destructively in Photoshop, and you want to learn all you 
can about how they work.

Layers allow you to make modifications to a document on a separate layer from the original 
pixels. This allows you to easily remove the changes, turn the changes off, or even stack dif-
ferent adjustments and reorder them. The Layer menu, shown in Figure 2.14, allows you to 
manage the layers in a document. Layers and the Layer menu are covered extensively in 
Chapter 10.

Examining the Type menu
The Type menu is built specifically for use with the Type tools. Using the Type menu gives 
you quick access to options such as opening the type panels, modifying size and orientation, 
and extruding type to 3D.

In addition, the Type menu, shown in Figure 2.15, allows you to modify type layers by raster-
izing them, to convert them to shape layers, or to warp them. You can also specify which lan-
guage to use for the fonts as long as the selected fonts support that language.
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FIGURE 2.14

The Layer menu in Photoshop provides several options to control the behavior of layers.

FIGURE 2.15

The Type menu in Photoshop provides several options to interact with text in your documents.

06_9781118123881-ch02.indd   3406_9781118123881-ch02.indd   34 3/29/12   3:10 PM3/29/12   3:10 PM



35

Chapter 2: Exploring the Photoshop Workspace

 2

Using the Select menu
Although you might not have thought that an entire menu could be dedicated to selections, 
they are such an integral part of many workflows in Photoshop that a selection menu is criti-
cal. The selection tools are some of the most powerful in Photoshop. They allow you to create 
masks, cut precise areas out of an image, and edit only specific parts of the image.

The Select menu, shown in Figure 2.16, gives you control over the selections. For instance, 
you can use the Select menu to select everything or deselect everything. You can also use the 
selection tools to access dialog boxes to modify an existing selection. The Toolbox contains 
several selection tools, and they are covered, along with the Select menu, in Chapter 9.

FIGURE 2.16

The Select menu in Photoshop provides several options to manage selections.

Exploring the Filter menu
Filters are placed over images to change their appearance. There are corrective filters such as 
Sharpen and Reduce Noise, and there are also special effects filters that can make your image 
look like it is being viewed through rippled glass or embossed into chrome. Filters are most 
definitely the fun side of Photoshop.

The Filter menu, shown in Figure 2.17, provides a list of several different filters that can be 
directly applied to an image. It also provides access to the Filter Gallery, which provides many 
more filters. You will learn more about filters and the Filter Gallery as well as how to use them 
and their menu options in Chapters 14 and 20.
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FIGURE 2.17

The Filter menu in Photoshop provides several filtering options that can be applied to images.

Understanding the 3D menu
The 3D menu, only available in CS6 Extended, is packed full of goodies for helping you work 
in the 3D environment. The 3D environment allows you to bring in 3D models and use the 
powerful Photoshop tools to make incredible changes to their appearance.

The 3D menu, shown in Figure 2.18, allows you to create and export 3D layers. It also provides 
access to several 3D utilities that allow you to perform tasks such as creating 3D extrusions 
and setting paint falloff. The 3D menu is covered in Chapter 22.

Using the View menu
The View menu functions as a catchall for everything that has to do with displaying docu-
ments in the Photoshop work area. Understanding this menu can be a great asset because 
it provides access to a plethora of tools, such as rulers and grids, that can enhance your 
workflow.
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FIGURE 2.18

The 3D menu in Photoshop provides access to several 3D options and tools.

As shown in Figure 2.19, the View menu offers basic options for adjusting the view of your 
document, such as its size (fit screen, actual pixels, print size, and so on) and screen mode 
(full screen, full screen with menus, and standard screen) that we discussed earlier in this 
chapter.

Proof Options

The proof options let you soft-proof your documents before printing; these settings are cov-
ered in more detail in Chapter 29. Options for setting pixel aspect ratios are available as well; 
these settings are for use with video files and are covered in Chapter 25.
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FIGURE 2.19

The View menu in Photoshop allows you to customize how documents are displayed in the 
Photoshop workspace.

Extras and Show

You may find it interesting that the Extras option allows you to see non-printing guides such 
as selections, bounding boxes, and grids. If you deselect the Extras option, any of these items 
that are visible in your document disappear.

The Show submenu lets you customize which non-printing items are visible when Extras is 
selected in the View menu. The following is a list of some of the features that you can enable 
using the Show submenu (refer to Figure 2.19):

n Layer Edges. This option places a bounding box around the edge of the currently 
selected layer.

n Selection Edges. This option shows marching ants around the selection. This is on by 
default when you make a selection. However, you can toggle it on and off afterwards.
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n Target Path. This option toggles displaying the target path on and off.

n Grid. This option places a mesh of vertical and horizontal lines, shown in Figure 2.20, 
that you can use to see the alignment and organization of objects more easily in your 
images. Photoshop also divides the grids into subdivisions of lines that are not as vis-
ible but are visible enough to be useful.

 A great feature of Photoshop is that you can force items to be snapped to grids by 
choosing View ➪ Snap To ➪ Grid from the Photoshop menu bar. This option is useful 
when placing images, text, and shapes in a document. You can configure the number 
of grid lines, colors, and styles in the Preferences dialog box, discussed later in this 
chapter.

FIGURE 2.20

The guides, grids, and rulers features of Photoshop allow you to better organize and 
align objects in your images.

Ruler unitsGuides Ruler

Subdivisions

Grids
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n Guides. This option helps you with object placement and organization. Guides are 
vertical or horizontal lines that you can add to a document by choosing View ➪ New 
Guide. You can force items to snap to guides by choosing View ➪ Snap To ➪ Guides 
from the Photoshop menu bar. The position of guides can be adjusted in the image by 
using the Move tool.

TIP

When you click and hold the mouse button on the ruler, the cursor changes to a guide adjustment cursor. You can 

quickly add guides to an image by clicking the ruler and dragging them into the document. 

n Smart Guides. This option toggles the viewing of smart guides on and off.

n Slices. This option toggles the slice overlay on and off. Chapter 30 discusses slices in 
more detail as part of preparing images for the web.

n Notes. This option toggles the display of notes you have added to the document on 
and off.

n Pixel Grid. This option toggles the display of the pixel grid on and off.

n 3D elements. These options toggle the display of some of the 3D elements on and 
off, such as cameras and lights. We discuss 3D in more detail in Chapters 22 
through 24.

n Brush Preview. This option toggles the brush preview for the bristle and erodible tip 
brushes. These brush tips, as well as the preview, are discussed in Chapter 16.

n Mesh. This option toggles the display of the mesh on and off when using the Puppet 
Warp tool. We discuss the Puppet Warp tool in Chapter 19.

n Edit Pins. This option toggles the display of edit pins on and off when using the 
Puppet Warp tool. We discuss the Puppet Warp tool in Chapter 19.

Rulers

Select the Ruler option if you want rulers to appear in your document window. When rulers 
are enabled, a vertical ruler is displayed on the left and a horizontal ruler is displayed on the 
top of the document window (refer to Figure 2.20).

The rulers start at zero in the upper-left corner of your document and measure the actual 
print size of your document. You can change the rulers’ unit of measure by right-clicking a 
ruler and selecting the unit from the shortcut menu. While you are moving the cursor over 
the documents, the exact placement of the cursor is noted in the ruler by a line that moves 
with the mouse.
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Snap and Snap To

As you move things around in your work area, whether they are selections, panels, or objects, 
you can choose to have them snap to the guides or to other objects. For instance, as you cus-
tomize your panels, they snap together so you can easily place them next to each other with 
no space between them and no overlaps.

The Snap To option lets you choose what elements your objects snap to: guides, grids, layers, 
and so on. The elements that have a check mark will draw objects you are moving like a mag-
net. If you want to place elements without the guides snapping them one way or the other, 
just deselect Snap in the View menu and you have full control.

New Guide, Lock Guides, and Clear Guides

The line under text and the bounding box around a placement in your document are guides 
that help you see and move these objects. You can make your own guides to help you with 
placement and alignment in your document. Choose View ➪ New Guide, and select whether 
you want the guide to run vertically or horizontally and where you want it placed in your 
image. The New Guide dialog box asks you how many inches into your image you want the 
guide placed, so it’s helpful to have the rulers on. You can also express the position of the 
guide as a percentage rather than a specific measurement.

You can lock these guides so you don’t accidentally move them by choosing Lock Guides. You 
can also clear them out of the way entirely by choosing Clear Guides.

Lock Slices and Clear Slices

The Lock Slices option allows you to lock slices to prevent them from being altered, and the 
Clear Slices option allows you to clear the existing slices so you can easily clean them up. 
Chapter 30 discusses slices in more detail as part of preparing images for the web.

Exploring the Window menu
The Window menu is used for three main purposes in Photoshop: first, it provides access to 
the Arrange and Workspace submenus that we have already discussed in this chapter; second, 
it provides a list of the available panels that you can toggle on and off; and finally, it pro-
vides a list of open documents that you can use to select a specific document so that it 
becomes active.

One of the best and most common uses of the Window menu, shown in Figure 2.21, is to tog-
gle panels on and off. The Window menu provides a comprehensive list of the panels that are 
available to you. From this menu, you can select the panels that you want to be visible. When 
a panel is visible, a check mark appears next to it. Selecting a visible panel hides the panel; 
selecting a hidden panel makes the panel visible. The different panels are discussed later in 
this chapter.
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FIGURE 2.21

The Window menu in Photoshop allows you to configure the workspace by defining the 
arrangement of documents and specifying which panels are visible.

Using the Help menu
The Help menu contains information about the Photoshop version that you are currently run-
ning, as well as links to online help for Photoshop. You can also use the Help menu to see 
which plug-ins are installed.

NOTE

On a Mac, the About and Plug-in menu options are in the Photoshop menu item on the left of the Photoshop menu bar. 

The Help menu, shown in Figure 2.22, contains web links to various sites that Adobe thinks 
might be of interest to you, such as the Photoshop Support Center and Photoshop Online. You 
can also use the Help menu to register, deactivate, and update your version of Photoshop. The 
two menu options worth noting are Photoshop Help and Deactivate.
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FIGURE 2.22

The Help menu in Photoshop provides access to online help for Photoshop.

Photoshop Help

Photoshop Help is a great resource if you are stuck figuring something out. Click the Help 
link, and you are taken to the Photoshop Help website where you can browse through the 
Help contents, search the Adobe Help resources, or even view articles and threads from others 
who are looking for or offering help.

Deactivate

When you install Photoshop on your computer and activate it, Adobe keeps a record of it. 
After you have installed Photoshop twice using the single-user application, Adobe deactivates 
your product to prevent further use. This obviously keeps you from passing your copy of 
Photoshop to your friends, neighbors, and your cousin’s boyfriend’s sister-in-law.

The Help ➪ Deactivate option allows you to deactivate the Photoshop license on the computer 
from which you run it. Upon deactivating, Photoshop will not load properly; however, you can 
then activate the license again on another computer or even on the same computer. The 
Deactivation screen prompts you with these three options:

n Suspend Activation. This disables the license on this computer, allowing you to run 
Photoshop on another computer or do an uninstall and reinstall of Photoshop. The 
license remains on the computer.

n Deactivate Permanently. This permanently removes the Photoshop license from this 
computer. You need to completely re-enter the license to add it back to that com-
puter. Use this option if want to permanently remove the license from the computer, 
for example, if you are selling it or need to do a complete system restore that would 
wipe out all data.

n Cancel. This cancels you out of deactivation without taking action. Photoshop still 
runs normally.
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CAUTION

The Deactivate menu option is absolutely imperative for you to know if the Adobe anti-piracy policy lockout becomes a 

problem, or if you are restructuring your system or purchasing a new computer. In order to reinstall Photoshop on a new 

system, or if you need to replace the hard drive, you need to deactivate Photoshop. Go to the Help menu and choose 

Deactivate. Doing so allows you to activate your software the next time you install it. 

Exploring Panels
The panels in Photoshop are mini-applications with their own windows, controls, and menus. 
You rely heavily on the Photoshop panels to do most of your editing. Photoshop has many 
panels, each of which provides its own set of functionality. The functionality of some panels 
is limited, while other panels are almost applications in their own right. We will discuss each 
of the panels in detail throughout the book as we cover the features that they are used for. 
The purpose of this section is to familiarize you with the panels that are available. Figure 2.23 
shows the icons for each of the panels.

FIGURE 2.23

Photoshop provides several panels that each act as individual utilities. You can view these pan-
els by selecting them from the Window menu or clicking their icons.

LayersSwatches
Color

Styles

Brushes
Brush Presets

Clone Source

Timeline
Character
Paragraph

Character Styles
Paragraph Styles

Mini Bridge

Tool Presets

Channels
Paths

Histogram
Info

Layer Comps

Adjustments
Properties

Navigator
Actions
History

Measurement Log
Notes

As a quick guide, the following list describes the icons for each of the panels and where they 
are covered in the book:
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n Swatches. Provides a simple way to manage sets of colors that you use in different 
documents. See Chapter 4.

n Color. Allows you to quickly select any color in the possible ranges that Photoshop 
supports. See Chapter 4.

n Styles. Allows you to manage the style sets that can be applied by various tools when 
painting or applying filters. See Chapters 10 and 16.

n Brushes. Provides a robust interface that allows you to define different types of 
brush qualities and behaviors that are used by Brush tools. See Chapter 16.

n Brush Presets. Allows you to easily manage sets of brushes that can be used by the 
various Brush tools. See Chapter 16.

n Clone Source. Provides a dynamic interface to control the source used by the Clone 
tools to heal areas of photos and remove unwanted items. See Chapter 15.

n Timeline (Extended only). Provides a timeline-based utility that adds animation to 
images. See Chapter 26.

n Character. Provides options to quickly format character styles, fonts, and spacing of 
textual elements in images. See Chapter 18.

n Paragraph. Provides options to quickly format paragraph styles and spacing of tex-
tual elements in images. See Chapter 18.

n Character Styles. Allows you to create and save character style settings that enable 
you to keep text consistent between documents. See Chapter 18.

n Paragraph Styles. Allows you to create and save paragraph style settings that enable 
you to keep text consistent between documents. See Chapter 18.

n Mini-Bridge. Provides some of the functionality of Bridge that allows you to quickly 
select and organize image files. See Chapter 6.

n Tool Presets. Allows you to quickly view and select presets for the tool that is cur-
rently selected in the Toolbox.

n Layers. Allows you to select, create, edit, and manage layers. This is one of the pan-
els you’ll use most often. See Chapter 10.

n Channels. Allows you to view and manage each of the different color channels in an 
image as well as create additional channels such as alpha channels. See Chapter 11.

n Paths. Allows you to manage and use vector paths in images. See Chapter 17.

n Histogram. Provides a simple-to-understand view of the overall distribution of color 
and levels in an image. See Chapter 4.

n Info. Allows you to view color and other information about individual pixels in the 
image by hovering the mouse over them. See Chapter 4.

n Layer Comps. Allows you to easily create, manage, and view multiple versions of a 
layout in a single Photoshop file. See Chapter 10.

n Adjustments. Allows you to apply several adjustments to a layer in an image. See 
Chapters 10 and 13.
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n Properties. Provides an additional interface with properties pertaining to other pan-
els, such as adjustments. This has replaced the Masks panel where you create and 
control masks. See Chapter 10.

n Navigator. Provides a simple interface that allows you to quickly zoom in on areas of 
an image. The interface includes a slider control at the bottom that zooms in on the 
image. It also displays a miniature version of the image with a red rectangle that you 
can move to pan to a specific area of the image, as shown in Figure 2.24.

n Actions. Allows you to record and then reapply a series of commands that perform 
common tasks such as applying filter settings. See Chapter 5.

n History. Provides access to the history states of the document that are recorded each 
time you change the document. See Chapter 5.

FIGURE 2.24

The Navigator panel allows you to quickly zoom in on the image in the document 
window and then pan to specific locations.

n Measurement Log. Keeps track of measurements as discussed earlier in this chapter.

n Notes. Allows you to view and manage notes that you create with the Note tool. This 
is discussed later in this chapter.

Understanding the Tools in the Toolbox
The Toolbox provides easy access to all the tools that you use to interact directly with pixels 
in the document window. To enable or disable the Toolbox, choose Window ➪ Tools from the 
Photoshop menu bar.

You can expand most of the tools in the Toolbox by pressing and holding the mouse button 
over them to reveal several other tools. Figure 2.25 shows the expanded menus of the 
Toolbox. From the expanded tool menus, you can select other tools. The icon of the currently 
selected tool is displayed in the Toolbox, and the cursor changes to reflect the current tool 
as well.
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FIGURE 2.25

Photoshop provides several tool sets in the Toolbox, and you can expand the tool sets to 
reveal additional tools.

Shape Selection tools
Lasso Selection tools

Quick Selection tools

Eye Droppper/Ruler/Note/Count tools

Brush tools

History Brush tools

Gradient/Paint Bucket tools

Dodge/Burn/Sponge tools

Text tools

Shape tools

Zoom tool

Crop and Slice tools

Healing tools

Stamp tools

Eraser tools

Blur/Sharpen/Smudge tools

Path Creation tools

Path Selection tools

Hand/Rotate View tools

Background/Foreground

Edit in Quick Mask mode

Screen modes

Move tool
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NOTE

As you select different tools in the Toolbox, the options bar changes to reflect specific options for these tools. The set-

tings in the options bar define the behavior of the tool selected in the Toolbox and extend the tool’s capabilities. When 

you change a tool’s settings and then use other tools, the settings for that tool remain the same when you return to it. 

Just as with panels, the tools in the Toolbox are covered in various sections throughout the 
book. The purpose of this section is to familiarize you with the organization of the Toolbox 
and what kinds of tools you can find there.

TIP

A great feature in Photoshop is the ability to quickly select and even temporarily switch tools on the fly. In many of the 

tool sets, you see a letter on the right side of the tools. Pressing that letter on the keyboard selects that tool set. 

Pressing and holding the Shift key while pressing the letter toggles through the different tools in the tool set. You can 

temporarily switch tools by pressing and holding the letter key for the tool while you use it, and when you release the 

key, Photoshop reverts to the original tool. For example, if you press and hold the V key when another tool is selected, 

Photoshop temporarily changes to the Move tool and you can move objects. When you are finished moving items, 

release the V key and the tool reverts to the original tool. 

The following list briefly describes each of the tool sets in the Toolbox, as well as where you 
can find more information about them in this book:

n Move tool. This is the only tool that allows you to move items in the document win-
dow. It allows you to move several items, including guides, objects and shapes in 
shape layers, and text objects.

n Shape Selection tools. These tools allow you to quickly select areas of the document 
using rectangle, ellipse, row, and column shapes. See Chapter 9.

n Lasso Selection tools. These tools allow you to quickly select areas of the document 
by using the mouse to draw a lasso around them. See Chapter 9.

n Quick Selection tools. These tools can intelligently select areas of the document by 
detecting areas that are similar to those selected by the mouse. See Chapter 9.

n Crop and Slice tools. The Crop tool lets you select an area of the document to keep 
and remove the area around it. See Chapter 3. The Slice tools are used for creating 
clickable hot areas for web images. See Chapter 30.

n Eye Dropper/Ruler/Note/Count tools. This tool set is a catchall. The Eyedropper tool 
is used to select foreground colors directly from pixels in the image. See Chapter 4. 
The Ruler tool is used to measure areas in an image. The Note tool allows you to add 
notes to an image that help you retain information such as to-do editing lists with 
the image. The Count tool allows you to count and log items in the image, which can 
be useful if you are working with medical images. The Ruler, Note, and Count tools 
were discussed earlier in the menus section of this chapter.

06_9781118123881-ch02.indd   4806_9781118123881-ch02.indd   48 3/29/12   3:10 PM3/29/12   3:10 PM



49

Chapter 2: Exploring the Photoshop Workspace

 2

n Healing tools. These tools provide quick ways to apply brush strokes that can heal areas 
of an image, from removing dust and scratches to removing red eye. See Chapter 15.

n Brush tools. These tools allow you to apply painting techniques to repair, enhance, 
and create images. See Chapter 16.

n Stamp tools. These tools include the Clone Stamp and Pattern Stamp. The Clone 
Stamp tool allows you to select an area of the image and then stamp or brush that 
area into other parts of the image or even other documents. See Chapter 15. The 
Pattern Stamp tool allows you to apply a style pattern to an image using brush 
strokes. See Chapter 16.

n Eraser tools. These tools allow you to quickly remove pixel data from an image. See 
Chapter 16.

n History Brush tools. These tools are used to repair and enhance areas of an image by 
painting data from previous editing states of the image. For example, you could 
change the image to grayscale and then use brush strokes to add color to specific 
areas. See Chapter 5.

n Blur/Sharpen/Smudge tools. The Blur and Sharpen tools allow you to use brush 
strokes to blur or sharpen specific areas of an image. The Smudge tool allows you to 
use brush strokes to smudge existing pixels into each other. See Chapter 16.

n Gradient/Paint Bucket tools. The Gradient tool allows you to paint a gradient pat-
tern onto an image. The Paint Bucket tool allows you to apply a paint color to sec-
tions of an image. See Chapter 16.

n Dodge/Burn/Sponge tools. The Dodge and Burn tools allow you to use brush strokes 
to lighten or darken areas of an image. The Sponge tool allows you to use brush 
strokes to remove or add color saturation in areas of an image. See Chapter 16.

n Path Creation tools. These tools allow you to create vector paths by creating lines 
between anchor points. See Chapter 17.

n Path Selection tools. These tools allow you to select and manipulate vector paths by 
adjusting the anchor points. See Chapter 17.

n Text tools. These tools allow you to add textual elements to images. See Chapter 18.

n Shape tools. These tools enable you to create and manipulate simple geometric vector 
shapes and lines as well as custom vector shapes. See Chapter 17.

n Hand/Rotate View tools. The Hand tool enables you to grab onto the image and pan 
by dragging the mouse. This feature is available only when you are zoomed in on the 
image, but it’s very useful for navigating around your image. The Rotate View tool 
allows you to rotate the canvas in the document window by dragging with the mouse. 
If you press and hold the Shift key while rotating the canvas, the rotation occurs in 
15-degree increments. Rotating the canvas can be useful if you need to align elements 
in the image with the vertical or horizontal axis of the display screen for editing.

n Zoom tool. This tool allows you to use the mouse to drag a specific rectangle to zoom 
in on the image. You can also zoom in at 100-percent increments by simply clicking 
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the document with the mouse. You can zoom out at 100-percent increments by press-
ing and holding the Shift key while clicking the document. The options bar for the 
Zoom tool provides several buttons to resize the document view based on actual pix-
els, print size, and screen size.

 If you have OpenGL Drawing enabled, then you can use the Scrubby Zoom option in 
the Zoom tool options bar. When you enable Scrubby Zoom, you can click and drag 
the mouse to the left and right on the image to zoom in and out.

n Background/Foreground. This section of the Toolbox allows you to see and modify 
the current background and foreground colors. The foreground color is used by sev-
eral tools to paint onto the image. The background color is used by several tools when 
removing pixels from the image. See Chapter 4.

TIP

Pressing D on the keyboard resets the foreground and background colors to black and white, respectively. Pressing X on 

the keyboard swaps the foreground and background colors. 

 The foreground is represented by the front square, and the background by the back 
square. The color of each is changed by clicking the square to launch a color chooser. 
The two colors can be switched by clicking the curved line with arrows on each end. 
To revert to the default colors of black and white, click the small black-and-white 
icon.

n Edit in Quick Mask mode. This option toggles between Normal and Quick Mask mode. 
The Edit in Quick Mask mode option allows you to tweak selections using the Brush 
tool to paint the exact shape. See Chapter 9.

n Screen Mode. This option allows you to quickly toggle between Standard, Full Screen, 
and Full Screen with Menu Bar modes.

TIP

You can activate the Quick Mask mode by pressing Q on the keyboard whenever you have an active selection in the 

document. 

Configuring Presets
As you become more familiar with the options that are available for different tool panels in 
Photoshop, you realize that it takes a while to optimize some tool settings and panels for 
what you need them to do. If you have to do that over and over, it can become time consum-
ing. That’s where presets come into play.

A preset is simply a collection of saved settings that you can easily reload to make a tool 
behave the exact same way each time the preset is used. Presets are organized into sets that 
can be loaded for each tool or panel and then easily selected. You will work with presets 
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throughout the book, but this section is designed to familiarize you with what presets are and 
the tools that you use to select and manage them.

Selecting tool presets
The simplest way to select tool presets is from the Preset menu option found in every tool 
options bar, as shown in Figure 2.26. For the Crop tool, you see presets for each of the stan-
dard photo sizes. Selecting one of the presets configures the Crop tool to crop the image to 
the specific size without your having to change the settings manually.

FIGURE 2.26

The Presets option in the options bar allows you to quickly configure settings for the tool by 
selecting a preset from a list of tool configurations.

Preset list New Tool Preset

Preconfigured presets list

From the preset menu shown in Figure 2.26, you have the following options:

n Preset list. Displays a list of presets. When you select an item from the list, the 
options in the tool are set to the values that are stored in the preset.

n Current Tool Only. Displays only presets that pertain to the current tool when this 
box is checked.
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n New Tool Preset. Enables you to store the current tool settings as a preset when you 
click this button. The new preset is displayed in the preset list.

n Rename Tool Preset. Allows you to change the display name of a tool preset so that 
you can refer to it more easily. You may end up adding several new presets, so you 
should keep the names specific.

n Delete Tool Preset. Removes the selected tool preset from the list.

n Sort by Tool. Sorts the preset list by tool rather than alphabetically when selected.

n Show All Tool Presets. Displays all available tool presets in the Preset list when 
checked. This is useful to switch between tools without selecting them from the 
Toolbox.

n Show Current Tool Presets. Displays the tool presets for only the currently active 
tool when checked. If you have a lot of tool presets, then you may want to check this 
item so that it is easier to find them.

n Display options. Allow you to display the list as text only, or to include small or 
large tool icons.

n Reset Tool. Resets the settings of the current tool to the default Photoshop values.

n Reset All Tools. Resets all tools to the default Photoshop values.

n Preset Manager. Launches the Preset Manager, which we will discuss in the next section.

n Reset Tool Presets. Resets the current list of tool presets to the stored values. This 
allows you to discard any changes you have made and go back to the last time you 
saved them.

n Load Tool Presets. Loads a set of tool presets that have previously been saved.

n Save Tool Presets. Saves the current tool presets to disk for later retrieval.

n Replace Tool Presets. Replaces the current tool presets with one that has been stored 
on disk.

n Preconfigured Presets list. Lists preconfigured presets. For example, the Airbrushes 
presets contain several brush tip presets for airbrushing and the Crop and Marquee 
presets contain several presets for the Crop tool.

NOTE

You can select presets from the Tool Presets panel. If you deselect the Current Tool Only option, the list in the tool 

options bar and in the Tool Presets panel displays all currently loaded presets instead of just those for the current tool. 

Selecting a preset switches to that tool with the appropriate settings. 

Managing presets
Presets are organized into sets, and each set is saved as a separate file on the file system. The 
Preset Manager allows you to create, load, and manage the sets of tool presets. To access the 
Preset Manager, choose Edit ➪ Preset Manager, or click the menu icon of the Preset list shown 
in Figure 2.27 and choose Preset Manager from the menu.
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FIGURE 2.27

The Preset Manager allows you to load, save, and manage presets for Photoshop tools as well 
as other types of settings such as brushes, text, and colors.

Preset list Preset Manager menu
Preset list 

Display options

Reset options

Preconfigured presets

Saved presets

The Preset Manager provides the Preset Type option that allows you to select the preset types. 
In addition to tool presets, you find presets for paintbrushes, color swatches, styles, and oth-
ers. When you select a different type, the list of presets changes to reflect the presets for that 
type.

You can use the mouse to select presets from the list, including any new ones you have cre-
ated, and then use the Save Set button to save the selected presets as a new set. To load addi-
tional presets, click the Load button. When you try to load a new set, you are prompted to 
add the set to the current list or to append the loaded set to the existing list.

Clicking the Preset Manager Menu button loads a menu similar to the one in Figure 2.27. The 
menu is different for each preset type, but they are all organized into the following sections:

n List options. This option defines how to display the presets. You can select text only, 
lists with icons, and different sizes of icons, depending on the preset type.

n Reset/Replace options. The Reset Tool Presets option resets the preset list for the 
selected preset type to the Photoshop default. This is a must when you begin 
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tweaking lists and appending sets. The Replace Tool Presets option allows you to load 
a preset list from a file on disk and replace the current preset list.

n Preconfigured presets. Photoshop provides several preconfigured presets that can be 
applied to the current set. The list of preconfigured presets is different for each pre-
set type. When you select one of these sets, you are prompted to either replace the 
current list or append the new list to the current list.

Creating presets
When you make changes to a tool’s settings in the options bar, Photoshop will remember 
those settings the next time you select the tool. At times, you will want to quickly toggle 
between different customized settings. The best way to handle this workflow is to create pre-
sets for each of the custom settings. Creating your own custom presets saves you valuable 
time adjusting settings that you use frequently.

Presets are created differently, depending on what type of preset you are creating.

Follow these steps to create a new tool preset:

 1. Select a tool from the Toolbox.

 2. Adjust the settings in the options bar.

 3. Open the Preset option for the tool (refer to Figure 2.27).

 4. Click the New Preset button.

 5. Enter the name that you want to use for the preset, and click OK.

  This permanently saves the preset in the Preset Manager until you delete it.

Follow these steps to create a custom style preset:

 1. Select a layer that is not locked.

 2. Select one of the options in the Add a Layer Style button at the bottom of the 
Layers panel to launch the Layer Style dialog box.

 3. Adjust the options for each effect to be included in the preset.

 4. Click the New Style button in the Layer Style dialog box, and name the preset.

Follow these steps to create a custom brush or pattern preset:

 1. Select the pixels you want to use to create the brush or pattern.

  We discuss area selections in Chapter 9.

 2. Choose Edit ➪ Define Brush Preset or Edit ➪ Define Pattern from the Photoshop 
menu bar.

 3. Name the brush or pattern and click OK.

 4. Select the Brush tool if you are creating a custom brush preset.

 5. Refine the brush or pattern by adjusting the settings in the Brushes panel.
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Follow these steps to create a custom shape preset:

 1. Create a path.

 2. Select the path in the Paths panel.

 3. Choose Edit ➪ Define Custom Shape from the Photoshop menu bar.

 4. Name the shape preset.

Follow these steps to create a custom color swatch preset:

 1. Click the Foreground color in the Toolbox to launch a Color Picker.

 2. Define the custom color.

 3. Hover the mouse cursor over a blank area in the Swatches panel until the cursor 
changes to a paint bucket.

 4. Click to add the color to the swatches.

NOTE

When you save preset lists, the filename must be saved with the appropriate file extension. This actually makes the pre-

set files easy to locate later when Photoshop searches the file system if you forget where you saved them. The default 

extensions are brushes (.abr), color swatches (.aco), contours (.sch), custom shapes (.csh), gradients (.grd), patterns 

(.pat), styles (.asl), and tools (.tpl). 

Setting Preferences
Setting the preferences allows you to work in a customized environment that feels comfort-
able to you. Whether you like to have cursors that are more precise or you want your rulers to 
show centimeters instead of inches, you can make a variety of changes using the Preferences 
dialog box.

The preferences are under the Edit menu, so choose Edit ➪ Preferences ➪ General on Windows 
and Photoshop ➪ Preferences ➪ General on the Mac to open the Preferences dialog box in the 
General pane, as shown in Figure 2.28. All the options available in the Preferences menu are 
also available in the left pane of the Preferences dialog box, with the exception of the Camera 
Raw preferences. Simply click one to display the pane you want.

Before you get started setting preferences, though, you’ll probably want to know how to 
restore the Adobe presets, just in case. To restore all the settings to the Adobe Photoshop 
defaults, press and hold the Ctrl+Alt+Shift/Ô+Option+Shift keys while you open Photoshop. 
You are asked if you want to delete the current settings. You have a second option if you are 
running Mac OS: Open the Preferences folder inside the Library folder, and drag the CS set-
tings to the trash. The folder is automatically re-created the next time Photoshop starts.
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FIGURE 2.28

The Preferences dialog box allows you to customize many of the settings in Photoshop.

Before you get started setting preferences, though, you’ll probably want to know how to 
restore the Adobe presets, just in case. To restore all the settings to the Adobe Photoshop 
defaults, press and hold the Ctrl+Alt+Shift/Ô+Option+Shift keys while you open Photoshop. 
You are asked if you want to delete the current settings. You have a second option if you are 
running Mac OS: Open the Preferences folder inside the Library folder, and drag the CS set-
tings to the trash. The folder is automatically re-created the next time Photoshop starts.

NOTE

The Library folder in the user’s home directory is hidden on the Mac, so you will need to hold down the Option key while 

clicking on the Go menu to have it appear in the menu. 

Updating General preferences
The General preferences panel provides you with the ability to control different aspects of the 
Photoshop environment. This panel has several basic options that either apply to Photoshop 
as a whole or just don’t fit well into any other menu. This is the place to start looking if you 
need to find a setting that doesn’t directly apply to any of the other preferences panels. From 
the General preferences panel, you can set the following options:
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n Color Picker. When Photoshop operations require you to choose a color, you choose a 
new background or foreground color using the color picker displayed in the Toolbox. 
You use a color picker to choose a color. A color picker usually takes the form of a 
color wheel or a color palette. The Adobe color picker appears by default, and in many 
cases it’s the best choice; it was custom designed for Photoshop, after all. You also 
have the option to use the standard color picker for your operating system — Mac OS 
or Windows. For Macs, you will be able to choose from a variety of color pickers such 
as a wheel and spectrum. At some point, you may install plug-ins that give you addi-
tional color picker options. They also display in the Color Picker drop-down menu.

n HUD Color Picker. When you select this option, it allows you to define the style of 
color picker that is used by the HUD (Heads Up Display).

n Image Interpolation. When images are resized, transformed, or otherwise manipu-
lated, pixels are added or taken away to make up the difference. This is called inter-
polation, and the method of interpolation determines not only the quality of the 
resulting image, but also the speed with which the image is processed. Figure 2.29 
shows examples of an image of a rose enlarged five times using each method of inter-
polation. We zoomed in so the difference would be much more obvious.

NOTE

You can change the image interpolation in the Image Size dialog box. A menu includes all the options available. The 

option you set in the preferences becomes the default option in the Image Size dialog box. 

n Nearest Neighbor (preserves hard edges). This option simply copies the pixels 
and creates identical pixels next to them. This is a much faster process, but for 
obvious reasons, it creates an image with jagged edges.

n Bi-linear. This option takes the four surrounding pixels and averages them to cre-
ate a new pixel. This creates a softer look than the Nearest Neighbor option, 
resulting in a smoother image but at the sacrifice of sharpness.

n Bicubic (best for smooth gradients). This option goes one better than the 
Bi-linear option by using the eight surrounding pixels to create an average. It also 
creates more contrast between the pixels, restoring some sharpness to the image.

n Bicubic Smoother (best for enlargement). This option is designed to create the 
smoothest possible transition when enlarging an image. It reduces the jagged 
edges and overall “filled-in” look you get when pixels are created to fill in the 
gaps of an image.

n Bicubic Sharper (best for reduction). This option uses the Bicubic method of 
interpolation and adds a sharpening filter to further increase the sharpness of the 
pixels. This option is best for reducing the image size.
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FIGURE 2.29

The image interpolation option affects the quality and look of the final image.

Nearest Neighbor Bi-linear

Bicubic Bicubic Smoother

Bicubic Sharper

06_9781118123881-ch02.indd   5806_9781118123881-ch02.indd   58 3/29/12   3:10 PM3/29/12   3:10 PM



59

Chapter 2: Exploring the Photoshop Workspace

 2

NOTE

It should be obvious from reading about image interpolation that the more you manipulate an image, the more that 

image deteriorates. Although some changes are usually necessary to get the results you desire, be careful how many 

steps you take to create those changes. If you want to make an image smaller, for instance, and you reduce it more 

than you anticipated, don’t just make the reduced image larger. Step backward and undo the first resize and then try 

reducing again. You may also want to check out some of the third-party plug-ins available on the Adobe Marketplace 

website for enlarging images. 

n Auto-Update Open Documents. This option tells Photoshop to automatically check 
the hard disk for changes made to any open file, and to update the file to reflect the 
saved changes. The best time to use this option is when two or more collaborators are 
working on the same file and you want to keep up with the changes being made by 
others.

n Beep When Done. This option causes Photoshop to beep whenever it finishes an 
operation. This is useful if you are making less obvious changes and want to be sure 
the operation is finished, or you’re performing more time-consuming operations and 
you want to walk away from your computer while they process.

n Dynamic Color Sliders. When you open the Adobe color picker, you use a color slider 
to change the range of colors visible in the color selection box. With Dynamic Color 
Sliders turned on, as you move the slider, the box changes color in real time. The 
only reason to turn off this option is if you are using a computer that was built some-
time in the last millennium and it just can’t handle the real-time change without 
slowing you down.

n Export Clipboard. This option allows you to copy or cut content from Photoshop and 
paste it into other applications by copying the Photoshop clipboard to the operating 
system’s Clipboard.

n Use Shift Key for Tool Switch. This option allows you to switch tools by pressing the 
Shift key and the hotkey. If this option is turned off, pressing the hotkey more than 
once cycles through the available tools. The Toolbox includes “tool drawers,” where 
one or more tools hide behind the visible icons in the Toolbox. Hotkeys also provide 
access to these tools.

n Resize Image During Place. This option resizes a placed image to fit the destination 
document into which you are pasting it. For instance, if you are placing a very large 
file into an open image that is much smaller, the document resizes to fit into the 
smaller canvas area. If this option is not turned on, the larger document may overlap 
the canvas area, hiding the entire image. Keep in mind that any resizing compromises 
the image quality and should be kept to a minimum if possible.

n Animated Zoom. This option allows you to continuously zoom with the Zoom tool by 
pressing and holding the left mouse button. It’s a great way to control how far you 
want to zoom in (or out), but be warned: it can be a little slow with larger files.
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n Zoom Resizes Windows. This option works only if you are using floating windows for 
each of your documents. These windows are resized as your images are resized. This 
eliminates the white space around images that have been reduced and keeps the 
images that you’ve zoomed into in view, instead of hanging out of the edges of your 
window. If you use floating windows a lot, we suggest turning this option on.

n Zoom with Scroll Wheel. This is our personal favorite zoom preference. With this 
option activated, you can use the scroll wheel of your mouse, if it has one, to zoom 
in and out of the selected image. No looking around for the Zoom tool or trying to 
remember its hotkey; just use the scroll wheel, and you can take a closer look at that 
area of your image you are trying to get just right and then zoom right back out to 
fit it in the screen.

n Zoom Point Clicked to Center. This option extends the function of the Zoom tool. 
When you click an area of your image with the Zoom tool, it zooms into that area 
generally, but with the Zoom Point Clicked to Center option turned on, the area you 
click becomes the center of the zoomed image.

n Enable Flick Panning. This option enables you to pan smoothly around an image. 
You can use the Hand tool to click the document, drag quickly, and then release the 
mouse button, and the document continues to pan just as if you had flicked it.

n HUD Vertical Movement varies Round Brush Hardness. This option affects the 
Heads Up Display (HUD). When you select it, vertical movements in the HUD adjust 
the hardness of the Round Brush tip instead of the opacity.

n Place or Drag Raster Images as Smart Objects. This option allows you to drag and 
place raster images in layers. Photoshop does this by temporarily converting them to 
Smart Objects and then back to raster images. This option can use a lot of processing 
power, so you should enable it only if you are willing to sacrifice some computer 
speed.

n Snap Vector Tools and Transforms to Pixel Grid. This option automatically snaps 
edits done by vector tools and transforms to the pixel grid.

n History Log. This option lets you keep a log of what editing has been done to the file 
using the following settings:

n Save Log Items To. This option lets you store the history as metadata inside the 
actual image file, as a separate text file, or both. Keeping a log as metadata makes 
the history data easy to transfer between systems, but it increases the size of the 
file, and you need to remove the history before distributing it to others.

n Edit Log Items. This option allows you to specify how detailed the history is. The 
Sessions Only option records only the date and time you edit the file in 
Photoshop. The Concise option also records the text that appears in the History 
panel. The Detailed option also records the commands used to edit the file. 
Obviously, the more detailed the history, the more the file size grows.

n Reset All Warning Dialogs. This option enables any warning dialog boxes that have 
been disabled when you selected a warning dialog box’s “Don’t Show Again” option.
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Arranging Interface preferences
The Interface preferences pane provides options for you to configure how the Photoshop 
workspace looks and performs. For example, you can specify colors and how panels behave. 
The Interface pane, shown in Figure 2.30, allows you to define the general look of the 
Photoshop interface, including windows, panels, and documents, using the following settings:

FIGURE 2.30

The Interface settings in the Preferences dialog box allow you to define the look and feel of 
the windows, documents, and panels in Photoshop.

n Appearance. These options define the general appearance of Photoshop by setting 
the following options:

n Color Theme. Allows you to select from four different Dark UI color themes. Each 
of these themes will set the menu, option bar, panel and document window back-
ground colors to different levels of darkness. This is a great feature to quickly 
change the appearance to be darker if you prefer to work in a darker UI.

n Standard Screen Mode. Allows you to define the background color and border of 
windows when working in the standard screen mode.

n Full Screen with Menus. Allows you to define the background color and border of 
windows when working in the full screen with windows mode.

n Full Screen. Allows you to define the background color and border of windows 
when working in the full screen mode.
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n Panels & Documents. When these options are selected, they define the behavior of 
panels and document windows using the following options:

n Auto-Collapse Iconic Panels. When enabled, panels that are opened by clicking 
the panel icon close automatically when you click another panel or tool in the 
workspace.

n Auto-Show Hidden Panels. When enabled, this reveals hidden panels on rollover.

n Open Documents as Tabs. When enabled, files are opened in tabbed document 
windows that are docked to the document workspace. When disabled, files are 
opened in a floating document window.

n Enable Floating Document Window Docking. When selected, you can dock float-
ing document windows with each other to make floating document groups that 
can be controlled together.

n Show Channels in Color. By default, channels are displayed in grayscale when 
you view them individually. Displaying the channels in color can give you a better 
perspective on the color, but it’s not the best option when trying to determine 
tonal adjustments that need to be made to an individual channel. See Chapter 11.

n Show Transformation Values. When you click the down-arrow, the list specifies 
where to display the contextual transformation value next to the cursor. You can 
specify never to turn them off or to display them at top right, top left, bottom 
right, or bottom left.

n Restore Default Workspaces. When clicked, this button resets the workspace to 
the default settings. Photoshop keeps track of the panels that are opened and 
layout changes that you make to the current workspace. When you open the 
workspace again, the panels return to the way you left them.

n Show Menu Colors. When selected, the colors that you define by choosing 
Edit ➪ Menus or Window ➪ Workspace ➪ Keyboard Shortcuts & Menus ➪ Menus are 
displayed in the menus. The ability to toggle this option on and off can be useful 
if the menu colors are distracting for some of your workflows.

n Show Tool Tips. When selected, a textual description of tools, settings, windows, 
and panels is displayed when you hover the mouse over these items.

n Enable Text Drop Shadows. When selected, text on panels has a drop shadow. 
This can make the interface look better.

n User Interface Text option. When selected, this allows you to set the language and 
font size used for the text in the Photoshop menus, tools, panels, and so on. You 
need to restart Photoshop after changing these settings.

Setting File Handling preferences
You can use the File Handling preferences to configure options for saving files, such as back-
ground saves, auto recovery, and file compatibility. The File Handling preferences pane, 
shown in Figure 2.31, provides the following settings to define behavior when saving files:
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FIGURE 2.31

The File Handling settings in the Preferences dialog box allow you to configure options such 
as compatibility settings for when you save files.

n File Saving Options. These options control the following behavior when saving files:

n Image Previews. This option controls whether to save the preview thumbnail 
data to a file when you save the image. Options are Never Save, Always Save, or 
Ask When Saving.

n File Extension. This option specifies to save the extension in uppercase or lower-
case format.

n Save As to Original Folder. This option causes Photoshop to default to the origi-
nal folder the file was opened from when you choose File ➪ Save As.

n Save in Background. This option saves images in the background rather than 
asking you to wait. This can be extremely useful when you are trying to work 
with large images. You can save them and go back to working on them while 
Photoshop works on saving them.

n Automatically Save Recovery Information Every. This option saves recovery 
information necessary to restore files in case a serious computer problem forces 
Photoshop to shut down. This is a great feature, but it also affects performance 
while the current file recovery data is being saved, especially if you have several 
files open. If Photoshop or your computer does crash, the files that were open will 
be opened again with ‘recovery’ in the filename, and you have the option of sav-
ing any work that was lost before the last recovery save. The default interval is 10 
minutes; however, you can change this value to suit your needs.
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n File Compatibility. These options provide the following settings for file compatibility 
when saving files:

n Camera Raw Preferences. This button launches a dialog box where you can set 
Camera Raw preferences. See Chapter 7 for more information about Camera Raw 
settings.

n Prefer Adobe Camera Raw for Supported Raw Files. This option causes Camera 
Raw files to be opened by Adobe Camera Raw instead of other applications, 
including Photoshop.

n Ignore EXIF Profile Tag. This option can help you to determine whether your 
camera has faulty color data. EXIF information is data about a photo that is 
embedded by a digital camera when the photo is taken. Cameras typically embed 
color profile data with the image to help ensure color correctness. However, if the 
camera has faulty color data, the image may not look as good as it should.

fl If your photos aren’t looking quite right, select this option and see if they look better. If not, you may 

need to deselect this option for images taken with that camera. You may also try assigning a different 

color profile to the image, as discussed in Chapter 29. 

n Ask Before Saving Layered TIFF Files. This option prompts you before layers are 
saved in a TIFF file to make certain you don’t want to flatten the file. We recom-
mend keeping the TIFF layers since it is the best way to keep the file in a very 
editable state with the full range of data. However, saving layers in the TIFF file 
may result in a much larger file size, and some applications that support TIFFs do 
not support layers. Keep this setting on, just as a reminder when saving TIFF files.

n Disable Compression of PSD and PSB Files. This option disables Photoshop from 
compressing PSD or PSB files. This increases the compatibility and slightly 
improves quality in certain settings; however, it also increases the size of the file 
on disk.

n Maximize PSD and PSB File Compatibility. This option controls whether 
Photoshop tries to maximize the PSD compatibility between older versions of 
Photoshop when you save an image. Options are Never, Always, or Ask. 
Maximizing compatibility is good, but it comes at the cost of greater file size. This 
preference defaults to Ask, but if you know that you will never use an older ver-
sion of Photoshop, disabling it saves you an extra mouse click.

n Enable Adobe Drive. This option enables Adobe Version Cue through Adobe Drive, 
which manages file versions when multiple people need to work on the same files. 
Version Cue can track changes to a file as different people work on it. This option 
should be enabled only if you are using Version Cue.

n Recent File List Contains. This option specifies the number of files to show in the 
File ➪ Open Recent File list. You may want to change this option based on the type of 
project that you are working on.
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Adjusting Performance preferences
The Performance preferences pane in Photoshop provides options that allow you to configure 
settings that can help it perform better. Photoshop is a very memory- and disk-intensive appli-
cation and as such, the better you adjust the performance, the faster it can perform complex 
operations such as Puppet Warp and Liquify. There are several settings that you can adjust in 
Photoshop, such as scratch disks, memory usage, and graphics processing, to improve its per-
formance. The Performance preferences pane, shown in Figure 2.32, provides the following set-
tings to improve some of the Photoshop features that are performance-intensive:

FIGURE 2.32

The Performance settings in the Preferences dialog box allow you to limit Photoshop so it 
does not consume resources on your system.

n Memory Usage. This section defines how much system memory Photoshop is allowed 
to consume. It displays the current system memory and gives a suggested range. The 
slider and text box define the maximum amount of RAM Photoshop is allowed to use. 
Processing images is very CPU- and RAM-intensive. The more RAM you allow 
Photoshop to consume, the faster it performs; however, less memory is available for 
other applications.

CAUTION

Allowing Photoshop to consume too much memory can lead to extremely poor system performance that affects all appli-

cations, even Photoshop. This is one case where more is not necessarily better. 

n Scratch Disks. This section displays a list of devices that you can select for scratch 
disks. Photoshop uses scratch disks to cache data not currently being used when it is 
processing data that requires more memory than the system has available.
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TIP

You get the best performance when working with Photoshop if you use three separate disk drives to store the Photoshop 

application, scratch data, and image files. This is because the disks can be seeking the three types of data at the same 

time. Keep in mind that putting 3 USB disks on the same hub will create a bottleneck that will actually degrade perfor-

mance in some cases. 

n History & Cache. This section defines settings for document caching and history 
retention that can improve how Photoshop performs. You have the following choices:

n Optimize buttons. These three buttons optimize the cache for documents that 
are Tall and Thin, the Default size, or Big and Flat. These options take into 
account your computer hardware and current system settings.

n History States. This option specifies the number of history states to cache. These 
history states are accessible from the History panel, as described in Chapter 5. A 
higher number gives you more states that you can use to backtrack changes but 
consumes more memory.

n Cache Levels. This option allows you to define the behavior of the cache. Caching 
improves performance by storing lower-resolution versions of the image to display 
in the document window. This allows for much faster rendering by Photoshop. A 
setting of 1 essentially disables caching because the full image size is stored in 
the cache. This gives you a more accurate view of the image but results in slower 
rendering times. Increasing the cache number stores more low-resolution versions 
of the image, which improves performance while sacrificing rendering quality in 
Photoshop. You need to restart Photoshop for changes to the cache to take effect.

n Cache Tile Size. This option specifies the number of bytes that Photoshop stores 
or processes at once. Typically, the rule is to use a larger tile size when working 
with larger images and a smaller tile size when working with smaller images or 
images with a lot of layers. You need to restart Photoshop for changes to the 
Cache Tile Size to take effect.

n Graphics Processor Settings. This section contains the Use Graphics Processor 
option, which allows you to enable or disable OpenGL drawing by your video adapter. 
OpenGL drawing uses the processor on your graphics adapter to render images. Using 
the video adapter to draw can significantly improve performance in many of the 
Photoshop features such as the Zoom, 3D, and Paint tools. Enabling OpenGL also 
enables several advanced features in Photoshop, such as the rotate view, bird’s-eye 
zooming, pixel grid, and flick to scroll.

 Clicking the Advanced Settings button loads the Advanced Graphics Processor Settings 
dialog box, shown in Figure 2.32, that allows you to choose from the following draw-
ing modes for OpenGL:

n Basic mode. This mode uses the smallest amount of GPU memory and has the 
least impact on other applications running OpenGL features on the system. 
However, it can result in slowness in some areas of Photoshop that are GPU-
intensive, such as 3D.
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n Normal mode. This mode uses the greatest amount of GPU memory and enables 
additional OpenGL features, but may cause visual defects on some GPUs.

n Advanced mode. This mode uses the same amount of memory as Normal mode 
but enables even more OpenGL features that can improve performance and 
enhance some of the Photoshop rendering features such as zoom animation. This 
mode may also cause visual defects on some GPUs and interfere with other appli-
cations using the GPU.

n Use Graphics Processor to Accelerate Computation. This option improves the 
performance-heavy processing operations such as the Puppet Warp preview.

n Use OpenCL. This option turns on the OpenCL processing to improve performance 
if it is supported by the graphics adapter.

n Anti-alias Guides and Paths. This option causes Photoshop to anti-alias guides 
and paths, which makes them render more cleanly on screen. However, this also 
slightly impacts performance.

n 30 Bit Display. This option increases the color fidelity on the monitor to 30 bits 
if it is supported.

Configuring Cursors preferences
One of the most important tools in Photoshop is the cursor. The cursor tells you where you 
are in the document, which in turn allows you to make precise edits and selections. The 
Cursor preferences allow you to configure the cursors to best fit your needs. The Cursors pref-
erences pane, shown in Figure 2.33, provides the following settings to define the appearance 
and size of mouse or stylus cursors:

n Painting Cursors. This section defines the appearance and size of the cursor used 
with painting tools such as the brush. You can choose from these options:

n Standard. This looks like the painting tool icon.

n Precise. This displays a crosshair, which is much better for seeing the exact cen-
ter of the brush stroke.

n Normal Brush Tip. This creates a circle the size of the paint stroke, not taking 
into account any feathering caused by brush settings. This option is better for 
seeing the immediate area that will be affected by the brush stroke.

n Full Size Brush Tip. This creates a circle that is the full pixel size of the paint 
stroke, including any feathered edges. This option is better for seeing the full 
area that will be affected by the brush stroke.

n Show Crosshair in Brush Tip. This displays a crosshair in the center of the 
Normal and Full Size Brush tips.

n Show Only Crosshairs While Painting. This changes from the Normal Brush Tip 
or Full Size Brush Tip to the Crosshair Tip when you are dragging the mouse. This 
allows you to see the size of the brush better before using the precision tip.
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n Other Cursors. This section defines the brush tip cursor used for tools other than the 
painting tool.

n Brush Preview. This section allows you to use a color chooser to define the color that 
is used for the brush editing preview.

FIGURE 2.33

The Cursors settings in the Preferences dialog box allow you to set the size and appearance of 
cursors when working with the Photoshop tools.

Setting Transparency & Gamut preferences
The Transparency & Gamut preferences pane is used to configure how transparent pixels 
appear in the document workspace. This allows you to distinguish transparent pixels from the 
background color. This pane, shown in Figure 2.34, provides the following settings to define 
the appearance of the transparency grid and gamut warning:
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FIGURE 2.34

The Transparency & Gamut settings in the Preferences dialog box allow you to define the 
appearance of the transparency grid and gamut warning.

n Transparency Settings. This section allows you to set the size and colors of the grid 
used to denote transparent pixels in an image. The Grid Size options are None, Small, 
Medium, and Large. The Grid Colors setting provides several predefined color sets, or 
you can select Custom to choose your own set of colors for the grid. Typically, you 
have no reason to adjust the transparency colors unless you have a pattern that is 
similar in the image you are editing.

n Gamut Warning. This section allows you to specify the color used to warn you when 
a color is out of range for a specified color profile — for example, when you choose 
View ➪ Gamut Warning or are previewing inside the Print dialog box (File ➪ Print). The 
Opacity setting defines how transparent or opaque the gamut warning is when dis-
played. Reducing the opacity allows you to more easily see the image behind the 
gamut warning.

Using Units & Rulers preferences
The Units & Rulers preferences pane enables Photoshop to be versatile in representing mea-
surements of rulers, text, and images. For example, you may want to use inches when editing 
one image and centimeters in another, or you may want to measure your text in millimeters 
instead of points. The Units & Rulers preferences pane, shown in Figure 2.35, provides the fol-
lowing settings to define the units, column sizes, document resolution, and point size to use 
in Photoshop:
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FIGURE 2.35

The Units & Rulers settings in the Preferences dialog box allow you to define the units, column 
sizes, document resolution, and point size.

n Units. This section allows you to control the units used by the rulers and with type. 
The Rulers option specifies the units used for rulers and measurements in Photoshop. 
The Type option specifies the units for all the settings used by the Type tools as well 
as the Character and Paragraph panels.

 The options are pixels, inches, centimeters, millimeters, points, picas, and percent 
(where percent is in relation to the size of the image). When working in a print work-
flow, using inches or picas is best. When working in a web workflow, using pixels is 
typically best.

n Column Size. This section is useful if you are preparing an image or multiple images 
that can be broken into columns. Several Photoshop dialog boxes use column width as 
a unit of measurement, including the New, Image Size, and Canvas Size dialog boxes. 
The columns in those dialog boxes are based on the Column Size settings.

n New Document Preset Resolutions. This section allows you to specify the default 
print and screen resolutions used when creating a new document with the File ➪ New 
command from the Photoshop menu bar. Keep in mind that the screen resolution is 
important for images that are viewed on a computer, such as web images, but print 
resolution determines the print quality and size of the printed image.
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n Point/Pica Size. This section allows you to set the number of points and picas in an 
inch. The PostScript method defines a pica as about 1/6 inch and a point as about 
1/72 inch. Applications from years ago used a different system where there were 6.06 
picas per inch and 72.27 points per inch. You should choose the Postscript setting 
unless you have a specific reason for using the traditional method.

Adjusting Guides, Grid, and Slices preferences
The Guides, Grid, and Slices preferences pane allows you to configure the color and look of 
guides, grids, and slices. Depending on the colors in the document you are working on, you 
may want to change the color of these lines to be more visible. Also, depending on how pre-
cise you would like to be in your image, you may want to make the grid spacing larger or 
smaller, especially if you are using the Snap to Grid feature. The Guides, Grid, and Slices pref-
erences pane, shown in Figure 2.36, provides the following settings to define the color, line 
style, and arrangement used when displaying guides, grids, and slice bounding boxes in the 
document window:

FIGURE 2.36

The Guides, Grid, and Slices settings in the Preferences dialog box allow you to define the 
color, line style, and arrangement used to display guides, gridlines, and slice bounding boxes 
in document windows.
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n Guides. This section allows you to set the color and line style for guides. You can 
choose any color from the menu or select Custom to launch a color chooser that lets 
you select any color Photoshop can display. You typically want to set the guide color 
to something that has a high contrast with the colors in the image so that you can 
see it better. You can also choose to make the guide a dashed or solid line.

n Smart Guides. This section allows you to set the color of the smart guides only. 
Smart guides are the lines that temporarily appear around the pixels on a layer when 
you move items. Smart guides are great at helping you align the content of one layer 
with the content of another layer.

n Grid. This section allows you to set the color and line style used when displaying the 
grid. You want to select a color that contrasts well with the image and also contrasts 
with the color of the guides so you can easily distinguish the lines from each other. 
You can also set the spacing between grid lines and the number of subdivisions to 
include between grid lines. Subdivisions show up as less apparent lines.

n Slices. This section allows you to specify the color of slice bounding boxes and 
whether to display the slice number when displaying the slice.

fl For more information about slices, see Chapter 30. 

Configuring Plug-ins preferences
Plug-ins are a very useful feature of Photoshop, allowing you to extend the product beyond 
its original programming. The Plug-ins preferences pane allows you to configure options that 
control the behavior of these plug-ins. The plug-ins preferences are discussed in Appendix B, 
along with several of the plug-ins that are available to add functionality to Photoshop.

Setting Type preferences
The Type preferences pane provides options to control the appearance and behavior of the 
type tools. You can use these options to do things such as enabling smart quotes that cannot 
be enabled in the type tools. The Type preferences pane, shown in Figure 2.37, provides the 
following settings to define behaviors such as using smart quotes and substituting fonts when 
adding text to images:

n Use Smart Quotes. When enabled, Photoshop scans through the text, detects the 
starting and ending quotation marks, and automatically converts them to quotes that 
curve toward the text inside the quotes. You may not want this option enabled if you 
are using text that contains a lot of single quotes — for example, using double 
quotes to signify inches and a single quote to signify feet.

fl For more information about fonts, glyphs, and adding text to images, see Chapter 18. 
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n Enable Missing Glyph Protection. When enabled, Photoshop automatically makes 
font substitutions for any missing glyphs that appear in the text, but not in the 
selected font. This option can be important if you are keeping text as a vector layer 
and transferring the file between machines. When loaded on the second machine, if 
the font is not present, Photoshop automatically makes a font substitution. If this 
option is disabled, Photoshop prompts you first.

n Show Font Names in English. When enabled, the names of fonts in the font list 
always appear in English, even if you are working with different language fonts.

FIGURE 2.37

The Type settings in the Preferences dialog box allow you to define behaviors such as using 
smart quotes and substituting fonts when adding text to images.

Adjusting 3D preferences
The 3D preferences pane in Photoshop Extended allows you to configure several features of 
the 3D tools. You can use these preference settings to enhance performance, improve object 
rendering, and define the look and feel of many of the 3D controls. The concepts surrounding 
3D preferences are tightly coupled with the 3D chapters in this book. Therefore, we included a 
description of the 3D preferences in Chapter 22. Refer to that chapter for information about 
setting 3D preferences.
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Customizing Shortcuts and Menus
Photoshop provides a tremendous amount of power by including a lot of features. 
Unfortunately, that means Photoshop also had to include a lot of menus. With the sheer num-
ber of menus and tools that Photoshop has to offer, you can quickly find yourself spending 
more time finding tools than using them. The solution to that problem is to customize your 
menus and to use keyboard shortcuts.

TIP

You can create and name several customized shortcuts or menu sets. You may want to create different sets for the type 

of editing you are doing and then load the set that best matches your workflow. 

Customizing menus
Photoshop allows you to customize the menus in two ways: you can hide menu items that you 
do not intend to use, or you can color code menu items to make them easier to find. To cus-
tomize the Photoshop menu bar, select Edit ➪ Menus from the Photoshop menu bar to display 
the Menus tab of the Keyboard Shortcuts and Menus dialog box, shown in Figure 2.38.

From the Menus tab, you can use the following options to create and manage customized 
menu sets:

n Set. This option allows you to select the default menu set or a saved menu set from 
the drop-down list. The Save Set icon next to the Set list allows you to save changes 
to the currently selected set. The New Set icon allows you to save the current menu 
configuration as a new set that is displayed in the Set list. The Delete Set icon 
removes the currently selected set from the list.

 To create a new custom menu, first make all adjustments to the menus, then click the 
New Set icon, and finally name the set. You can then reload that set any time you 
like.

n Menu For. This option allows you to choose whether you want to edit the application 
menus or the panel menus. When you change this option, either the application or 
panel menus are displayed, depending on which option you choose.

n Menu list. This list displays a selection of menus that can be adjusted. You can 
expand and collapse a menu in the list by clicking the triangle next to the menu 
name. When the menu is expanded, you can customize each menu option by doing 
the following:

n Change visibility. You can use the mouse to toggle the eye icon to hide or show 
the menu item in Photoshop. Figure 2.38 shows that the Background option is 
hidden while the others are visible.

n Change color. You can change the color used for the background of the menu 
item. This allows you to color code certain menu types or highlight important 
menu items so you can more easily find them. To change the color, select a color 
from the drop-down menu shown in Figure 2.38.
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FIGURE 2.38

The Keyboard Shortcuts and Menus dialog box allows you to create custom menus that hide 
unwanted items and display important items in organized colors.

Menu list Save Set Delete Set

New Set

Hidden

ColorVisible

Customizing shortcuts
One of the best ways to speed up your workflow in Photoshop is by using keyboard shortcuts. 
Keyboard shortcuts allow you to use a key sequence to quickly perform tasks, select tools, and 
open panels. Throughout this book, we include the important keyboard shortcuts when 
describing various tools. If you take the time to learn and use these shortcuts, you will be 
more efficient at using Photoshop.

CAUTION

You should be careful not to use system wide shortcut combinations or shortcuts that are in use with other programs 

that you plan to use while you are using Photoshop. This can cause conflicts that result in confusion and mistakes. 

Photoshop also allows you to customize the keyboard shortcuts. To customize keyboard short-
cuts in Photoshop, choose Edit ➪ Keyboard Shortcuts from the Photoshop menu bar to display 
the Keyboard Shortcuts tab of the Keyboard Shortcuts and Menus dialog box, shown in Figure 
2.39.
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FIGURE 2.39

The Keyboard Shortcuts and Menus dialog box allows you to customize the keyboard short-
cuts that you use to perform common tasks in Photoshop.

From the Keyboard Shortcuts tab, you can use the following options to create customized key-
board shortcut sets:

n Set. This option allows you to select the default shortcut set or a saved shortcut set 
from the drop-down list. As with the customizing menus, the Save Set icon next to 
the Set list allows you to save changes to the currently selected set. The New Set icon 
allows you to save the current keyboard shortcuts as a new set that is displayed in 
the Set list. The Delete Set icon removes the currently selected set from the list.

 To create a new custom shortcut set, make all adjustments to the shortcuts, click the 
New Set icon, and name the set. You can then reload that set any time you like.

n Shortcuts For. This option allows you to select whether to edit the shortcuts for 
application menus, panel menus, or tools. When you change this option, the list 
below changes to reflect the option you choose.

n Use Legacy Channel Shortcuts. This option changes the channel switching shortcuts 
back to the pre-CS4 form for users who are familiar with those options.

n Item list. This list displays a selection of shortcuts for the type selected in the 
Shortcuts For option. You can expand and collapse items in the list by clicking the 
triangle next to the item name.
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 To change or add a shortcut to an item, click in the Shortcut column of that item. A 
text box appears with a cursor. When you type a key sequence into the text box, that 
key sequence is added to the text box. Figure 2.39 shows an example of the text box 
and key sequence for the Open menu item. To apply the key sequence as a shortcut, 
click the Accept button. To undo the change you made, click the Undo button. To 
revert to the Photoshop default, click the Use Default button.

n Add Shortcut. This button adds an additional shortcut to the item so it has two 
shortcuts. This may help if you are accustomed to different shortcuts from other 
applications.

n Delete Shortcut. This button removes the selected shortcut from the item.

n Summarize. This button launches a dialog box that allows you to select a location to 
store an HTML summary of the keyboard shortcuts. After the file is saved, the sum-
mary is automatically displayed in your default web browser, as shown in Figure 2.40. 
This is a good way to review the settings that you made.

fl Appendix A contains tables that provide a quick reference to the most commonly used keyboard 

shortcuts. 

FIGURE 2.40

The Summarize option of the Keyboard Shortcuts and Menus dialog box generates a 
viewable HTML document that displays the current keyboard shortcuts.
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Summary
This chapter discussed the Photoshop workspace, including the document windows, menus, 
panels, tools, and preferences. Photoshop provides a lot of power, and if you learn how to 
configure and use the workspace, you can be more efficient and have much more fun.

Photoshop provides an intuitive interface in most areas and some powerful features, such as 
grouping document windows and customizing menus, that enable you to speed up your 
workflow.

In this chapter, you learned the following:

n How to organize and arrange document windows

n What’s in all those menus

n How to use grids, rulers, and guidelines

n All about the tools in the Toolbox and where they are covered in this book

n How to organize panels

n How to create keyboard shortcuts to make Photoshop easier to use

n How to create and save tool presets so that you can easily configure tools for 
later use
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